#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-hj-np-zA-HJ-NP-Z0-9]{7}"
Local $sString = "047K04Z – Dilation of right femoral artery with drug-eluting intraluminal device, open approach" & @CRLF & _
"047K0DZ – Dilation of right femoral artery with intraluminal device, open approach" & @CRLF & _
"047K0ZZ – Dilation of right femoral artery, open approach" & @CRLF & _
"047K34Z – Dilation of right femoral artery with drug-eluting intraluminal device," & @CRLF & _
" percutaneous approach" & @CRLF & _
"047K3DZ – Dilation of right femoral artery with intraluminal device, percutaneous approach"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")