use strict;
my $str = '047K04Z – Dilation of right femoral artery with drug-eluting intraluminal device, open approach
047K0DZ – Dilation of right femoral artery with intraluminal device, open approach
047K0ZZ – Dilation of right femoral artery, open approach
047K34Z – Dilation of right femoral artery with drug-eluting intraluminal device,
percutaneous approach
047K3DZ – Dilation of right femoral artery with intraluminal device, percutaneous approach';
my $regex = qr/[a-hj-np-zA-HJ-NP-Z0-9]{7}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}