# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-hj-np-zA-HJ-NP-Z0-9]{7}"
test_str = ("047K04Z – Dilation of right femoral artery with drug-eluting intraluminal device, open approach\n"
"047K0DZ – Dilation of right femoral artery with intraluminal device, open approach\n"
"047K0ZZ – Dilation of right femoral artery, open approach\n"
"047K34Z – Dilation of right femoral artery with drug-eluting intraluminal device,\n"
" percutaneous approach\n"
"047K3DZ – Dilation of right femoral artery with intraluminal device, percutaneous approach")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.