const regex = /[a-hj-np-zA-HJ-NP-Z0-9]{7}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-hj-np-zA-HJ-NP-Z0-9]{7}', 'g')
const str = `047K04Z – Dilation of right femoral artery with drug-eluting intraluminal device, open approach
047K0DZ – Dilation of right femoral artery with intraluminal device, open approach
047K0ZZ – Dilation of right femoral artery, open approach
047K34Z – Dilation of right femoral artery with drug-eluting intraluminal device,
percutaneous approach
047K3DZ – Dilation of right femoral artery with intraluminal device, percutaneous approach`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}