using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-hj-np-zA-HJ-NP-Z0-9]{7}";
string input = @"047K04Z – Dilation of right femoral artery with drug-eluting intraluminal device, open approach
047K0DZ – Dilation of right femoral artery with intraluminal device, open approach
047K0ZZ – Dilation of right femoral artery, open approach
047K34Z – Dilation of right femoral artery with drug-eluting intraluminal device,
percutaneous approach
047K3DZ – Dilation of right femoral artery with intraluminal device, percutaneous approach";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}