package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-hj-np-zA-HJ-NP-Z0-9]{7}`)
var str = `047K04Z – Dilation of right femoral artery with drug-eluting intraluminal device, open approach
047K0DZ – Dilation of right femoral artery with intraluminal device, open approach
047K0ZZ – Dilation of right femoral artery, open approach
047K34Z – Dilation of right femoral artery with drug-eluting intraluminal device,
percutaneous approach
047K3DZ – Dilation of right femoral artery with intraluminal device, percutaneous approach`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}