# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!guión:\s)([\p{Lu}][\p{Ll}]+\b)/**\1**/ugm;t' <<< "guión: El computador. Ángel."