#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?um)(?<!guión:\s)([\p{Lu}][\p{Ll}]+\b)"
Local $sString = "guión: El computador. Ángel."
Local $sSubst = "**\1**"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)