$re = '/(?<!guión:\s)([\p{Lu}][\p{Ll}]+\b)/um';
$str = 'guión: El computador. Ángel.';
$subst = "**\1**";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;