re = /(?<!guión:\s)([\p{Lu}][\p{Ll}]+\b)/m
str = 'guión: El computador. Ángel.'
subst = '**\\1**'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result