const regex = /(?<!guión:\s)([\p{Lu}][\p{Ll}]+\b)/ugm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!guión:\\s)([\\p{Lu}][\\p{Ll}]+\\b)', 'ugm')
const str = `guión: El computador. Ángel.`;
const subst = `**\1**`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);