import re
regex = re.compile(r"(?<!guión:\s)([\p{Lu}][\p{Ll}]+\b)", flags=re.UNICODE | re.MULTILINE)
test_str = "guión: El computador. Ángel."
subst = "**\\1**"
result = regex.sub(subst, test_str)
if result:
print(result)