#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xus)#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>" & @CRLF & _
"(?>([!"#$%&'*+,.\/:;=?@^_`|~-])" & @CRLF & _
"|(\<)|(\()|(\[)|(\{))" & @CRLF & _
"#Непосредственно шаблон:" & @CRLF & _
"(?(?=.*[^\\]\1.*\1)(?R)|(.*))" & @CRLF & _
"#Закрываем" & @CRLF & _
"(?(1)\1)(?(2)\>)(?(3)\))(?(4)\])(?(5)\})" & @CRLF & _
"#Модификаторы шаблонов" & @CRLF & _
"([mixXsuUAJ]*)"
Local $sString = "/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>" & @CRLF & _
" (?:(\<)|(\()" & @CRLF & _
" |(\[)|(\{)" & @CRLF & _
" |([\!\"\#\$\%\&\'\*\+\,\.\/\:\;\=\?\@\^\_\`\|\~\-]))" & @CRLF & _
" <td>ii" & @CRLF & _
"#Непосредственно шаблон:" & @CRLF & _
"(?(?=.*[^\\]\5.*\5)(?R)|(.*))" & @CRLF & _
"#Закрываем\/" & @CRLF & _
"" & @CRLF & _
"((?:(?(1)\>)(?(2)\))" & @CRLF & _
" (?(3)\])(?(4)\})" & @CRLF & _
" (?(5)\5)))" & @CRLF & _
"#Модификаторы шаблонов" & @CRLF & _
" ([mixXsuUAJ]*)/xus" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")