const regex = /#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?>([!"#$%&'*+,.\/:;=?@^_`|~-])
|(\<)|(\()|(\[)|(\{))
#Непосредственно шаблон:
(?(?=.*[^\\]\1.*\1)(?R)|(.*))
#Закрываем
(?(1)\1)(?(2)\>)(?(3)\))(?(4)\])(?(5)\})
#Модификаторы шаблонов
([mixXsuUAJ]*)/us;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?>([!"#$%&\'*+,.\\\/:;=?@^_`|~-])
|(\\<)|(\\()|(\\[)|(\\{))
#Непосредственно шаблон:
(?(?=.*[^\\\\]\\1.*\\1)(?R)|(.*))
#Закрываем
(?(1)\\1)(?(2)\\>)(?(3)\\))(?(4)\\])(?(5)\\})
#Модификаторы шаблонов
([mixXsuUAJ]*)', 'us')
const str = `/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?:(\\<)|(\\()
|(\\[)|(\\{)
|([\\!\\"\\#\\\$\\%\\&\\'\\*\\+\\,\\.\\/\\:\\;\\=\\?\\@\\^\\_\\\`\\|\\~\\-]))
<td>ii
#Непосредственно шаблон:
(?(?=.*[^\\\\]\\5.*\\5)(?R)|(.*))
#Закрываем\\/
((?:(?(1)\\>)(?(2)\\))
(?(3)\\])(?(4)\\})
(?(5)\\5)))
#Модификаторы шаблонов
([mixXsuUAJ]*)/xus
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}