use strict;
my $str = '/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?:(\\<)|(\\()
|(\\[)|(\\{)
|([\\!\\"\\#\\$\\%\\&\\\'\\*\\+\\,\\.\\/\\:\\;\\=\\?\\@\\^\\_\\`\\|\\~\\-]))
<td>ii
#Непосредственно шаблон:
(?(?=.*[^\\\\]\\5.*\\5)(?R)|(.*))
#Закрываем\\/
((?:(?(1)\\>)(?(2)\\))
(?(3)\\])(?(4)\\})
(?(5)\\5)))
#Модификаторы шаблонов
([mixXsuUAJ]*)/xus
';
my $regex = qr/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?>([!"#$%&'*+,.\/:;=?@^_`|~-])
|(\<)|(\()|(\[)|(\{))
#Непосредственно шаблон:
(?(?=.*[^\\]\1.*\1)(?R)|(.*))
#Закрываем
(?(1)\1)(?(2)\>)(?(3)\))(?(4)\])(?(5)\})
#Модификаторы шаблонов
([mixXsuUAJ]*)/xusp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}