// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?xus)#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?>([!"#$%&'*+,.\/:;=?@^_`|~-])
|(\<)|(\()|(\[)|(\{))
#Непосредственно шаблон:
(?(?=.*[^\\]\1.*\1)(?R)|(.*))
#Закрываем
(?(1)\1)(?(2)\>)(?(3)\))(?(4)\])(?(5)\})
#Модификаторы шаблонов
([mixXsuUAJ]*)"##).unwrap();
let string = "/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?:(\\<)|(\\()
|(\\[)|(\\{)
|([\\!\\\"\\#\\$\\%\\&\\'\\*\\+\\,\\.\\/\\:\\;\\=\\?\\@\\^\\_\\`\\|\\~\\-]))
<td>ii
#Непосредственно шаблон:
(?(?=.*[^\\\\]\\5.*\\5)(?R)|(.*))
#Закрываем\\/
((?:(?(1)\\>)(?(2)\\))
(?(3)\\])(?(4)\\})
(?(5)\\5)))
#Модификаторы шаблонов
([mixXsuUAJ]*)/xus
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}