$re = '/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?>([!"#$%&\'*+,.\/:;=?@^_`|~-])
|(\<)|(\()|(\[)|(\{))
#Непосредственно шаблон:
(?(?=.*[^\\\\]\1.*\1)(?R)|(.*))
#Закрываем
(?(1)\1)(?(2)\>)(?(3)\))(?(4)\])(?(5)\})
#Модификаторы шаблонов
([mixXsuUAJ]*)/xus';
$str = '/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?:(\\<)|(\\()
|(\\[)|(\\{)
|([\\!\\"\\#\\$\\%\\&\\\'\\*\\+\\,\\.\\/\\:\\;\\=\\?\\@\\^\\_\\`\\|\\~\\-]))
<td>ii
#Непосредственно шаблон:
(?(?=.*[^\\\\]\\5.*\\5)(?R)|(.*))
#Закрываем\\/
((?:(?(1)\\>)(?(2)\\))
(?(3)\\])(?(4)\\})
(?(5)\\5)))
#Модификаторы шаблонов
([mixXsuUAJ]*)/xus
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);