import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"""
#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?>([!"#$%&'*+,.\/:;=?@^_`|~-])
|(\<)|(\()|(\[)|(\{))
#Непосредственно шаблон:
(?(?=.*[^\\]\1.*\1)(?R)|(.*))
#Закрываем
(?(1)\1)(?(2)\>)(?(3)\))(?(4)\])(?(5)\})
#Модификаторы шаблонов
([mixXsuUAJ]*)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = ##"""
/#Ограничитель не должен быть пробелом, цифрой, буквой, обратным слэшем, так же это может быть ()[]{}<>
(?:(\<)|(\()
|(\[)|(\{)
|([\!\"\#\$\%\&\'\*\+\,\.\/\:\;\=\?\@\^\_\`\|\~\-]))
<td>ii
#Непосредственно шаблон:
(?(?=.*[^\\]\5.*\5)(?R)|(.*))
#Закрываем\/
((?:(?(1)\>)(?(2)\))
(?(3)\])(?(4)\})
(?(5)\5)))
#Модификаторы шаблонов
([mixXsuUAJ]*)/xus
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}