package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"Description":.*?<td>CCGcode<\/td><td>(00C)<\/td>`)
var str = []byte(`"properties": {
"Name": "Darlington",
"Description": "<br><br><br> <table border=\"1\" padding=\"0\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>"
}
`)
var substitution = []byte(""CCGCode":"\1",\n \0")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}