re = /"Description":.*?<td>CCGcode<\/td><td>(00C)<\/td>/
str = '"properties": {
"Name": "Darlington",
"Description": "<br><br><br> <table border=\\"1\\" padding=\\"0\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>"
}
'
subst = '"CCGCode":"\\1",\\n \\0'
result = str.sub(re, subst)
# Print the result of the substitution
puts result