# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"Description\":.*?<td>CCGcode<\/td><td>(00C)<\/td>"
test_str = ("\"properties\": {\n"
" \"Name\": \"Darlington\",\n"
" \"Description\": \"<br><br><br> <table border=\\\"1\\\" padding=\\\"0\\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>\"\n"
"}\n")
subst = "\"CCGCode\":\"\\1\",\\n \\0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.