// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""Description":.*?<td>CCGcode<\/td><td>(00C)<\/td>"#).unwrap();
let string = "\"properties\": {
\"Name\": \"Darlington\",
\"Description\": \"<br><br><br> <table border=\\\"1\\\" padding=\\\"0\\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>\"
}
";
let substitution = "\"CCGCode\":\"\\1\",\\n \\0";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}