import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "translate\\(\n"
+ "(['\"])\n"
+ "(?:\n"
+ " .*?(?=\\1\\))\n"
+ ")\n"
+ "\\1\n"
+ "\\)";
final String string = "translate(\"some text here\")\n"
+ "translate('some text here')\n"
+ "translate('\"some text here...\"')\n"
+ "translate(\"a\\\"b\\\"c\\\"d\")\n"
+ "translate(\"\") here comes the sun\n"
+ "translate(\"a\\\"b\"c\\\"d\") and here's the moon\n"
+ "translate('this is ugly wrong\")\n"
+ "translate(\"as well as this')\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}