// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)translate\(
(['"])
(?:
.*?(?=\1\))
)
\1
\)"#).unwrap();
let string = "translate(\"some text here\")
translate('some text here')
translate('\"some text here...\"')
translate(\"a\\\"b\\\"c\\\"d\")
translate(\"\") here comes the sun
translate(\"a\\\"b\"c\\\"d\") and here's the moon
translate('this is ugly wrong\")
translate(\"as well as this')
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}