re = /translate\(
(['"])
(?:
.*?(?=\1\))
)
\1
\)/x
str = 'translate("some text here")
translate(\'some text here\')
translate(\'"some text here..."\')
translate("a\\"b\\"c\\"d")
translate("") here comes the sun
translate("a\\"b"c\\"d") and here\'s the moon
translate(\'this is ugly wrong")
translate("as well as this\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end