$re = '~translate\(
([\'"])
(?:
.*?(?=\1\))
)
\1
\)~x';
$str = 'translate("some text here")
translate(\'some text here\')
translate(\'"some text here..."\')
translate("a\\"b\\"c\\"d")
translate("") here comes the sun
translate("a\\"b"c\\"d") and here\'s the moon
translate(\'this is ugly wrong")
translate("as well as this\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);