#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\x00-\x7F\s]+"
Local $sString = "AlloCine - ByPass v.1 - UserCSS (userstyle)" & @CRLF & _
"AlloCiné sans Nag Screen" & @CRLF & _
"" & @CRLF & _
"Greasyfork - Add notes to the script" & @CRLF & _
"Ajouter une fonction de commentaire (alias/tag) au script pour aider à identifier et rechercher"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")