import Foundation
let pattern = #"[^\x00-\x7F\s]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
AlloCine - ByPass v.1 - UserCSS (userstyle)
AlloCiné sans Nag Screen
Greasyfork - Add notes to the script
Ajouter une fonction de commentaire (alias/tag) au script pour aider à identifier et rechercher
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)