// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^\x00-\x7F\s]+").unwrap();
let string = "AlloCine - ByPass v.1 - UserCSS (userstyle)
AlloCiné sans Nag Screen
Greasyfork - Add notes to the script
Ajouter une fonction de commentaire (alias/tag) au script pour aider à identifier et rechercher";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}