import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\x00-\\x7F\\s]+";
final String string = "AlloCine - ByPass v.1 - UserCSS (userstyle)\n"
+ "AlloCiné sans Nag Screen\n\n"
+ "Greasyfork - Add notes to the script\n"
+ "Ajouter une fonction de commentaire (alias/tag) au script pour aider à identifier et rechercher";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}