import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:ht|f)tps?:\\/\\/(\\w+\\.\\w{2}[\\/\\w-.]*))";
final String string = "http://matthiasweiss.at/asd/asd\n\n"
+ "ftp://hallo.welt\n\n"
+ "https://hallowelt.jpg\n\n"
+ "http://asdasd.aa/jojoji.jiji\n\n"
+ "mail@matthiasweiss.at\n\n"
+ "http://matthiasweiss.at\n\n\n\n\n\n\n";
final String subst = "<a href=\"$1\">$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}