#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0|[1-8]\d?|90?)(?:\.\d+)?$"
Local $sString = "91" & @CRLF & _
"90" & @CRLF & _
"90.45" & @CRLF & _
"90.9999" & @CRLF & _
"0" & @CRLF & _
"0.23" & @CRLF & _
"9" & @CRLF & _
"80" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")