import re
regex = re.compile(r"^(?:0|[1-8]\d?|90?)(?:\.\d+)?$", flags=re.MULTILINE)
test_str = ("91\n"
"90\n"
"90.45\n"
"90.9999\n"
"0\n"
"0.23\n"
"9\n"
"80\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")