package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:0|[1-8]\d?|90?)(?:\.\d+)?$`)
var str = `91
90
90.45
90.9999
0
0.23
9
80
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}