import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0|[1-8]\\d?|90?)(?:\\.\\d+)?$";
final String string = "91\n"
+ "90\n"
+ "90.45\n"
+ "90.9999\n"
+ "0\n"
+ "0.23\n"
+ "9\n"
+ "80\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}