$re = '/^(?:0|[1-8]\d?|90?)(?:\.\d+)?$/m';
$str = '91
90
90.45
90.9999
0
0.23
9
80
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);