using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^regio/([^/]+)/([^/]+)$";
string substitution = @"regio/$1/var=$2";
string input = @"regio/bar/foo
regio/something/blabla
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}