import re
regex = re.compile(r"^regio/([^/]+)/([^/]+)$", flags=re.MULTILINE)
test_str = ("regio/bar/foo\n"
"regio/something/blabla\n")
subst = "regio/$1/var=$2"
result = regex.sub(subst, test_str)
if result:
print(result)