package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^regio/([^/]+)/([^/]+)$`)
var str = `regio/bar/foo
regio/something/blabla
`
var substitution = "regio/$1/var=$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}