import Foundation
let pattern = #"^regio/([^/]+)/([^/]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
regio/bar/foo
regio/something/blabla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"regio/$1/var=$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)