#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?:[.]?\d+(?:\([a-z]+\))*)?"
Local $sString = "Sub-Clause 9.12" & @CRLF & _
"Clause 13" & @CRLF & _
"SubClauses 9.8, 9.9 and 9.10" & @CRLF & _
"Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii))" & @CRLF & _
"Sub-Clause 20.1(d)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")