import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:[.]?\\d+(?:\\([a-z]+\\))*)?";
final String string = "Sub-Clause 9.12\n"
+ "Clause 13\n"
+ "SubClauses 9.8, 9.9 and 9.10\n"
+ "Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii))\n"
+ "Sub-Clause 20.1(d)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}