re = /\d+(?:[.]?\d+(?:\([a-z]+\))*)?/m
str = 'Sub-Clause 9.12
Clause 13
SubClauses 9.8, 9.9 and 9.10
Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii))
Sub-Clause 20.1(d)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end