package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(?:[.]?\d+(?:\([a-z]+\))*)?`)
var str = `Sub-Clause 9.12
Clause 13
SubClauses 9.8, 9.9 and 9.10
Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii))
Sub-Clause 20.1(d)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}