const regex = new RegExp('\\d+(?:[.]?\\d+(?:\\([a-z]+\\))*)?', 'gm')
const str = `Sub-Clause 9.12
Clause 13
SubClauses 9.8, 9.9 and 9.10
Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii))
Sub-Clause 20.1(d)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}