using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:[.]?\d+(?:\([a-z]+\))*)?";
string input = @"Sub-Clause 9.12
Clause 13
SubClauses 9.8, 9.9 and 9.10
Sub-Clauses 17.1(b)(ii) and 17.3(b)(ii))
Sub-Clause 20.1(d)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}