using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\n]+)\s*([^\n]+) (\$[^\n]+)\s*([^\n]+)\s*([^\n]+)$";
string substitution = @"<p style=""color: #EF2F48""><b>$1</b></p><p>$2  $3</p> <p style=""color: #000"">$3</p> <p><a class=""ui-link"" style=""color: blue;""href=""$4"" target=""_blank"">$5</a></p>";
string input = @"190 PALMER RD, HARMONY
MLS® 201512263 $239,900
2 ACRES/HEATED DBL GARAGE/HEAT PUMP
http://goo.gl/tVWDan";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}