# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\n]+)\s*([^\n]+) (\$[^\n]+)\s*([^\n]+)\s*([^\n]+)$"
test_str = ("190 PALMER RD, HARMONY\n"
"MLS® 201512263 $239,900\n"
"2 ACRES/HEATED DBL GARAGE/HEAT PUMP\n"
"http://goo.gl/tVWDan")
subst = "<p style=\"color: #EF2F48\"><b>$1</b></p><p>$2  $3</p> <p style=\"color: #000\">$3</p> <p><a class=\"ui-link\" style=\"color: blue;\"href=\"$4\" target=\"_blank\">$5</a></p>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.