import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\n]+)\\s*([^\\n]+) (\\$[^\\n]+)\\s*([^\\n]+)\\s*([^\\n]+)$";
final String string = "190 PALMER RD, HARMONY\n"
+ "MLS® 201512263 $239,900\n"
+ "2 ACRES/HEATED DBL GARAGE/HEAT PUMP\n"
+ "http://goo.gl/tVWDan";
final String subst = "<p style=\"color: #EF2F48\"><b>$1</b></p><p>$2  $3</p> <p style=\"color: #000\">$3</p> <p><a class=\"ui-link\" style=\"color: blue;\"href=\"$4\" target=\"_blank\">$5</a></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}