const regex = /^([^\n]+)\s*([^\n]+) (\$[^\n]+)\s*([^\n]+)\s*([^\n]+)$/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\n]+)\\s*([^\\n]+) (\\$[^\\n]+)\\s*([^\\n]+)\\s*([^\\n]+)$', 'gsi')
const str = `190 PALMER RD, HARMONY
MLS® 201512263 \$239,900
2 ACRES/HEATED DBL GARAGE/HEAT PUMP
http://goo.gl/tVWDan`;
const subst = `<p style="color: #EF2F48"><b>$1</b></p><p>$2  $3</p> <p style="color: #000">$3</p> <p><a class="ui-link" style="color: blue;"href="$4" target="_blank">$5</a></p>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);